AVADirect Custom Computers Homepage
Forum Home Forum Home > Community > Technology News
  Active Topics Active Topics
  FAQ FAQ  Forum Search   Calendar   Register Register  Login Login

How Do Games Currently Run on Windows 7

 Post Reply Post Reply
Author
Message
  Topic Search Topic Search  Topic Options Topic Options
MattSlagle View Drop Down
AVADirect Guru
AVADirect Guru
Avatar

Joined: 03 Apr 2008
Location: AVA HQ
Posts: 1197
  Quote MattSlagle Quote  Post ReplyReply Direct Link To This Post Topic: How Do Games Currently Run on Windows 7
    Posted: 04 Feb 2009 at 3:22pm

How Do Games Currently Run on Windows 7

With Windows 7 being a beta, how can you be sure that your currently software library will run on this new OS from Microsoft.  With XP losing support very soon, and many users not liking the Vista experience, many people are using the Windows 7 beta as their main OS.  Well in this mini review brought to us by www.ExtremeTech.com, they list some older and newer games which worked and which did not work.

Games That Worked

Freespace 2. Note that this is not the original, disk-based version of Freepace 2, but the version you can buy for $5.99, DRM-free, from Good Old Games. It's still limited in some ways—supported resolutions, for example, are only 640x480 or 1024x768. But audio works fine and USB joysticks are recognized.

Mechwarrior: Mercenaries. This was the last Mechwarrior title from the now-shuttered FASA Studios, once part of Microsoft. It's limited to a maximum resolution of 1280x1024, but works fine with USB game controllers. The neat thing about older 3D titles is that you can crank up anti-aliasing and anisotropic filtering with no discernable performance hit. You can also max out all the graphics and detail settings.

Age of Wonders. This little turn-based gem of a strategy game ran without any hitches in Windows 7. The game owes much to the original Masters of Magic, and can be pretty addictive, in that "just one more turn" way. Bask in its 2D, spriteful glory!

Civilization III. Civ3 was the last of the 2D, sprite-based, resolution-limited games in the Civilization line. It ran without a hitch, but the graphics do show their age. The user interface just seems clunky compared to Civilization 4.

Civilization IV. Civ4 runs without any issues, at the full 1920x1200 resolution of the display.

Mount and Blade. This darling of an indie game has the best implemented of mounted combat we've ever seen, as well as an excellent melee combat system. We used the version available from Steam to test. It ran great, and we confess to playing it way too long to just call it a test...

Red Alert 3. Red Alert 3 runs with no problems. This latest iteration of the Red Alert series comes with so much cheese layered on in the dialog and cut scenes, you can just feel your cholesterol level climb. But it's good fun, in an overly-campy sort of way.

GRID. Codemaster's racing game is a blast, allowing you to drive a variety of different types of cars. GRID also runs perfectly on Windows 7.

Sins of a Solar Empire. We installed the disk-based version, rather than downloading it from Stardock's Impulse service. The game ran without a hitch.

Company of Heroes. Relic's superb World War II based real time strategy game was one of the first Games for Windows titles. It runs well on Windows 7 in both DX9 and DX10 modes. Fire it up for some visceral company level tactical combat.

Neverwinter Nights 2. We installed the original, plus the Mask of the Betrayer expansion. The game ran fine. I'm looking forward to running an Arcane Trickster in the expansion.

Ghost Recon 2. Ubisoft's tactical shooter seems to have no problems in Windows 7.

Titan Quest. Titan Quest, plus the Immortal Throne expansion, runs with no problems on Windows 7. This Diablo-like action RPG is a fun romp through Greece, Egypt, China and... other locales.

Enemy Territory: Quake Wars. This fast paced multiplayer action game from Splash Damage offers up terrific squad-based action. We were able to connect to a server on the Internet and dive in for some quick action.

Games That Worked..... With Issues

Quake II. We installed Quake II from an original install CD. Yes, Quake II runs. Frame rate is a little chunky, though. For one thing, the game is so old, that it didn't recognize the OpenGL driver that's part of the Nvidia driver set, so we were running in software mode—hence the limited performance, even on a fast system.

Left4Dead. This latest game using Valve's Source Engine works like a charm. So if you love your Zombie-whacking action, then Windows 7 won't keep you from it.  However, the post-game experience isn't perfect. Once you exit Left4Dead, we saw some corruption of the Windows desktop.  If you look at the upper left corner of the windows, and the frames around the windows, you'll see some odd artifacts. It may just be a problem with the Nvidia driver, but this is a beta OS...

Freelancer. This fabulous space-based action game from Microsoft still has a fan following to this day, with new mods being created and servers still up and running. You can install the single player game, and update with the 1.1 patch, and it will run just fine. Connecting to a multiplayer server is problematic. Part of the issue is that most servers are now running various mods, so you'll need to install those.  For more on Freelancer mods, check out Lancers Reactor and The Starport.  Even finding a server is problematic, since the Freelancer Global Server is no longer running. The Starport has a global server fix you can download, that lets you see other servers on the net.

Guild Wars. Despite installing from the original discs, Guild Wars doesn't show up in the Games Explorer. It is available from the Start Menu, as well as a desktop shortcut, and runs without any other issues.

Age of Empires III. When we first installed Age of Empires III, we got a pop-up dialog indicating that the game was incompatible with this version of Windows.  This is not a Windows 7 problem—you get this same error when trying to run the game on Windows Vista. Alas, the "Check for Solutions Online" doesn't find any, even though the fix is simple: install the game, then install the 1.11 or later patch. If you don't install the patch, the game runs, but with severe graphics corruption in the game screen.

Fallout 3. Fallout 3 is a pretty recent title, supports Games for Windows Live, and should be a poster child for a game that runs on Windows 7. In fact, it does run on Windows 7. However, getting the game installed is another problem entirely.  Note that we had no problems with the Fallout 3 launcher on our production system, which runs 64-bit Windows Vista.  You can manually launch setup by either navigating to the DVD and launching setup, or bringing up the Run dialog and typing "X:\setup.exe" where "X" is your DVD drive letter. Once we installed the game, it didn't appear in the Games Explorer. That's a fairly serious problem. Since this is a Games for Windows title, it doesn't show up in the start menu, either. Since the Fallout 3 launcher still crashed after the install, the only way to launch the game was to navigate to the game's own folder, and run the executable directly. Or you can drag a shortcut to the Games Exporer.  Interestingly, the main game folder has a little executable that's supposed to install Fallout 3 in the Games Explorer, called GDFInstaller.exe. So I thought I'd run this, which should add it to the Games Explorer. Except it doesn't:  At any rate, once you do find the executable, the game runs just fine.

Games That Did Not Work

Some games just won't run. Perhaps they have some old, 16-bit code. Maybe the authors just wrote too close to the metal. There are a host of reasons. In our testing, we ran into a pair of titles that refused to run. We're sure there are others, but our guess is that most of them also won't run well on Vista.

System Shock 2. It's no surprise this old classic won't run. It won't run on Vista, either, though we've had it to run on Windows XP in the past. You can install it, and get as far as the initial in-game screen. But the game is completely unresponsive to any controls—neither keyboard nor mouse have any effect.

Falcon 4: Allied Force. This hard core combat flight sim is based on the original Falcon 4 engine, with a new campaign and other modifications. You can run install and run the game. In fact, if you stay in the cockpit, everything seems to go well.  As soon as you pop out of the cockpit for an external view, though, it all goes FUBAR pretty quickly.  That's bad enough, but if you go to an external view, the system locks up hard after a couple of minutes. The keyboard is unresponsive, so only a trip to the reset button fixes the problem.

Link to the original article here.



Edited by MattSlagle - 05 Feb 2009 at 9:08am
Matt Slagle
AVADirect Research and Developement
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.032 seconds.